Performance Degradation and Timeouts
Incident Report for Stamped.io
Resolved
This incident has been resolved.
Posted May 18, 2022 - 17:56 UTC
Monitoring
The fix has been deployed, and operations should be resuming normal behavior, but we are continuing to monitor.
Posted May 18, 2022 - 16:54 UTC
Identified
An incident has occurred with the Stamped AWS Autoscaling cluster. This has resulted in degraded performance impacting multiple services. It has been identified, a fix has been implemented and is expected to be resolved shortly. We will be continuing to monitor and provide updates on this incident as it occurs.
Posted May 18, 2022 - 16:37 UTC
This incident affected: Admin Dashboard, Customer Interactions, Login, and API.