Degraded performance and Queue Delay
Incident Report for Stamped.io
Resolved
We have made some patches that improved overall performance and increased the processing of the review messages backlog.
Posted Sep 29, 2022 - 16:58 UTC
Investigating
We have been experiencing ongoing performance degradation since last evening in addition to delays in the reviews messaging queue that we are actively investigating the cause.

As a result of the performance degradation, you may experience an issue while accessing Stamped services during this time. This includes our Dashboard and the Stamped API.
With the reviews messaging queue, you may see delays in order status and the sending out of review requests.
Posted Sep 28, 2022 - 22:35 UTC
This incident affected: Admin Dashboard, Customer Interactions, Login, Integrations, API, and Review Processing.