Review Requests Sending Backlog
Incident Report for Stamped.io
Resolved
The current review requests sending backlog has been resolved.
Posted Jun 16, 2022 - 16:06 UTC
Monitoring
Minor backlog identified in the sending of review requests, reaching 1-2 day delay for certain larger customers. We expect a resolution in the next 2-3 days.
Posted Jun 14, 2022 - 23:35 UTC
This incident affected: Review Processing.