Server performance degradation
Incident Report for Stamped.io
Resolved
This incident has been resolved.
Posted Aug 09, 2022 - 08:04 UTC
Update
Maintenance has been completed, and all services have resumed and are showing performance within expected ranges.
Posted Aug 09, 2022 - 08:04 UTC
Identified
We have been experiencing ongoing performance degradation since this morning. From our investigation, we have isolated the cause of the issue to be our server cluster on AWS and are continuing to investigate in greater detail. As a result of the performance degradation, you may experience an issue while accessing Stamped services during this time. This includes our Dashboard and the Stamped API.

Our team is working tirelessly to resolve this and will be scheduling a maintenance period overnight during North America hours to implement necessary updates to our AWS server. Please note there will be no impairment to your data during the maintenance period but access to some of our services may be restricted during that time.
Posted Aug 08, 2022 - 17:48 UTC
This incident affected: Admin Dashboard, Customer Interactions, Login, Integrations, API, and Review Processing.